Stop DNS hijacking in windows

- disable DNS hijacking
- change DNS server
- setting up google as DNS server

What is DNS hijacking ?
- DNS redirecting

Why don’t I want it ?
- When I but a url that is not recognized it gets redirected to ads
- It interferes with avahi-daemon (zeroconf)

How do I know its occurring ?
- by typing a non existing url in the browser
- ping a non existing url
- in windows by running nslookup in the command line and seeing a foreign ip address

How to stop it ?
- setting up a specific router (
- or changing your computer dns server (

More ?
- in windows command line running ipconfig /all will show what dns server you’re running

time warner
bright house network

Zend 2 notes

# creating a new module folders
$ mkdir -p Album/{config,src/Album/{Controller,Form,Model},view/album/album}
# using zf.php,
$ vendor/bin/zf.php create module


Jquery .on() method not working on dynamic content

A page that executes javascript every time an input field it checked and also load new data thru ajax.

My jquery selector

$(".te_multiselect_checkbox").on("change", function( e ) {} 

was not working on the new content. When I ran $(‘.te_multiselect_checkbox’) in the console before the new content was retrieve I would get but after the new content was loaded I got
I dont know if this happens because the page was architect to do so or javascript is doing it.

What I learned is the selector is not getting the new content change the selector to

$(document.body).on('change', '.te_multiselect_checkbox', function( e ) {}

Here is the explanation:

jquery maintain selector when new ajax content
jquery get by class more than 100

Git on Windows passwordless with plink

Manual way:

Use Git on Windows with a private key by using pagent, putty and plink

Or the automatic way:

When installing “git on windows” on the “Choosing the SSH executable” screen choose “Use (Tortoise)Plink” and browse for plink.exe.

stackoverflow answer

pageant needs to be running and loged in with private key

git windows ssh private key

Vagrant: Fix VT-x/AMD-V hardware acceleration

Operating System: Windows 7
Motherboard: asus z-97-ar
Intel CPU: Intel Core i7-4790K

Does your CPU support virtualization?

Download software

You must enable Virtualization in BIOS
Advvance -> CPU Configurations -> Intel Virtualization Technology -> enable

The reasons I had to enable VT-x was because when I “vagrant up” I received these error

1. In the command like it got stuck on “default: Warning: Connection timeout. Retrying…”

2. in Oracle Virtualbox:
“VT-x/AMD-V hardware acceleration is not available on your system. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.”

So to resolve that I need to enable VT-x and in my Vagrant file add

config.vm.provider :virtualbox do |vb|
  vb.customize ["modifyvm", :id, "--hwvirtex", "on"]


homestead laravel

SSH Private Key conversion

In attempt to login into a ssh server using a private key in phpstorm I ran accross this error.

Keypair ‘private_key.ppk’ is corrupt or has unknown format. Only SSH2 keys in OpenSSH format or PuTTY Private Key *.ppk are supported. Error message: The cipher ‘aes256-cbc’ is required, but it is not available.

This error will not allow the “next” and “test connection” button to appear

The issue here is that the private key format is incorrect. You’ll will need to convert the private key to open ssh format. And the way to do that is

Open your private key in PuTTYGen
Top menu “Conversions”->”Export OpenSSH key”.
Save the new OpenSSH key when prompted.

Laravel Homestead Vagrant windows setup

video notes:
9:35 editing hosts files
6:13 putty ssh to vagrant server

# start vagrant
# inside C:\Users\username\Desktop\vagrant\Code
$ vagrant up

# the url will be

# vagrant for public access
# :public_network, ip: ""

# to allow symbolic links, ln -s
# in windows 7 you need to run the terminal as administrator