PuPHPet troubleshooting

You may avoid issues by using the MINGW32 terminal instead of something else.

 

Installed a new puphpet and the web page won’t show up.

  1. vagrant ssh
    • inside the puphpet folder
  2. $ telnet locahost 80
    • verify a successful response
  3. $ sudo service apache2 restart
    • if apache2: Configuration error: More than one MPM loaded.
      1. $ sudo a2dismod worker
      2. $ sudo service apache2 restart

If php file is being read as plain text.  This was a phpmyadmin issue

  1. run $ sudo apt-get install libapache2-mod-php5
  2.  restart apache

You may get an phpmyadmin error ‘phpmyadmin.pma_table_uiprefs doesn’t exist’ when you attempt to open database tables
http://stackoverflow.com/questions/20731487/phpmyadmin-pma-table-uiprefs-doesnt-exist#answer-24937839
run this command
$ sudo dpkg-reconfigure phpmyadmin

Vagrant: Fix VT-x/AMD-V hardware acceleration

Operating System: Windows 7
Motherboard: asus z-97-ar
Intel CPU: Intel Core i7-4790K

Does your CPU support virtualization?

Download software https://www.grc.com/securable.htm

You must enable Virtualization in BIOS
Advvance -> CPU Configurations -> Intel Virtualization Technology -> enable

The reasons I had to enable VT-x was because when I “vagrant up” I received these error

1. In the command like it got stuck on “default: Warning: Connection timeout. Retrying…”

2. in Oracle Virtualbox:
“VT-x/AMD-V hardware acceleration is not available on your system. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.”

So to resolve that I need to enable VT-x and in my Vagrant file add

config.vm.provider :virtualbox do |vb|
  vb.customize ["modifyvm", :id, "--hwvirtex", "on"]
end

Resources:
http://askubuntu.com/questions/41550/how-do-i-run-a-64-bit-guest-in-virtualbox#answer-41554

tags:
homestead laravel

Virtual Box Internet Issue

The problem:
unable to connect to internet
$ ping google (doesnt work)

What might cause the problem:
Added the ‘Host-only Adapter’ network to the virtual box

Solution:
remove static ip from /etc/network/interfaces (changed it back to dynamic)

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

#auto eth0
#iface eth0 inet static
#       address 192.168.0.108
#       netmask 255.255.255.0
#        network 192.168.0.0
#        broadcast 192.168.0.255
#        gateway 192.168.0.1

remove the 2nd network and only stayed with the 1st one (Bridged Adapter)

reflesh the MAC address (not sure if this help)

reboot

edit /etc/network/interfaces changed back to static ip address

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth0
#iface eth0 inet dhcp

auto eth0
iface eth0 inet static
        address 192.168.0.108
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

OR
edit using the GUI
http://askubuntu.com/questions/338442/how-to-set-static-ip-address#answer-338855

operating system:
Linux cowboy 3.12-kali1-686-pae #1 SMP Debian 3.12.6-2kali1 (2014-01-06) i686 GNU/Linux

Kali Linux Virtual Box


from video with minor changes relative to my computer

view-1 / main menu
Click new

view-2
name: kali linux
type: linux
version: debian

view-3
1025mb in ram (check the minimum on site)

view-4
create a virtual hard drive now

view-5
VDI (virtualBox Disk Image)

view-6
Dynamically allocated

view-7
20.23 GB (check website for minimum)

the partition is created
in main menu
click “green arrow” / “start”

browse for kali-linux-1.0.6-i386.iso
click start

kali linux start screen will appear and now you start installing

at the end
you will get an error to fix
so go to settings -> system -> processor and check “enable PAE/NX”