Ubuntu Adding Packages

When attempting to install a program thru apt-get the most frustrating moment is when the program cannot be found and what’s worst is not being able to add the package to install the program. In the past attempting to add packages by editing /etc/apt/sources.list has been unsuccessful but success has came from adding thru “apt-add-repository” command line command. Here are examples.

Where to find packages
https://launchpad.net/ubuntu/+ppas
ppa packages info

To install cmake:
# https://launchpad.net/~kalakris/+archive/cmake
$ sudo apt-add-repository ppa:kalakris/cmake
$ sudo apt-get update
$ sudo apt-get install cmake

To install emacsen-common:
# http://www.ubuntuupdates.org/ppa/kubuntu-ppa_backports?dist=precise
$ sudo add-apt-repository ppa:kubuntu-ppa/backports
$ sudo apt-get update
$ sudo apt-get install emacsen-common

To install cheese
# http://packages.ubuntu.com/precise/i386/cheese/download
# adding a line to your /etc/apt/sources.list like this:
deb http://cz.archive.ubuntu.com/ubuntu precise main universe
$ nano /etc/apt/sources.list
$ sudo apt-get update
$ sudo apt-get install cheese

View package info

$ apt-cache policy [package name]
# apt-cache policy cheese

Wireless Connecting but not Internet

Today I used wireless internet at a doctors office. When I arrived back home home my Dell Latitude computer could not connect to the internet wirelessly (could connect thru a ethernet cord). It showed as connected to my router but not the internet. There were no issues with the router and the internet because my iphone could surf the internet. It seems that when I connected to the internet at the clinic it messed up my PC. Here how I fixed it.

Right clicked on the “monitor in front of monitor” icon at the bottom right corner and selected “connect to network”.

Right clicked on the internet that I was trying to connect to and selected “diagnose”.

A new window opened and I clicked on an option that said something about “resetting the the ip address” (not exactly sure) and it showed a loading screen saying “repairing”. And that fixed it

tags:
wireless connecting but no internet